Latest Chrome browser update (v55) breaks Shoutcast v1.x HTML5 players (FIXED)

More Support

Level 2 Support
Staff member
Good News! It appears the Chrome team has decided to roll back the change:

After much discussion and looking at how many users this impacts, we plan on re-enabling HTTP/0.9 over ports other than 80 for Chrome 56. We'll remove it again in Chrome 57, but we'll also add a hack to allow it just for responses that look to be from Shoutcast servers (Ones that start with "ICY"). So behavior should be just like it was in Chrome 54 and earlier going forward, for Shoutcast servers (Worth noting this does not quite match FireFox's current behavior).
https://bugs.chromium.org/p/chromium/issues/detail?id=669800#c103

We still recommend upgrading to ShoutCast 2 though as shoutcast.com will likely remove version 1 stations at some point. We're not sure on the status of other browsers in the future either.
 

Gel

New Member
Last few days my 3 browsers won't stream from smoothjazzflorida url; No Web Player showing where play button should show. "Flash" functionality checked and that works fine. :( Tried multiple refreshes but still won't work.
 

Support

Level 1 Support
Staff member
Last few days my 3 browsers won't stream from smoothjazzflorida url; No Web Player showing where play button should show. "Flash" functionality checked and that works fine. :( Tried multiple refreshes but still won't work.
Hmmmm strange? It's working fine for us. We suggest perhaps try clearing your browsers cache and try again!
smoothjazzflorida.png
 

Support

Level 1 Support
Staff member
IE11/ AVANT /Edge
IE11/ Edge are rubbish in our opinion.. We think it's time that you moved to a better browser such as Chrome/Firefox. We cannot really help you much more with this as it is working fine for us (and others) and the previous Chrome update issue this thread relates to has since been rolled back in their latest update. I just tested this again in the Edge browser and it's still working as it should. By the way the player we use is HTML5, not Flash.

Pretty sure if you cleared the browsers cache's or tested this in a private window this will work for you.
 

Pilgrim

New Member
Is there any reason why this error would show up in Firefox if my station (Shadowy Realms) is a v2 Shoutcast station? The station is HTML5 friendly, as is evidenced by the functional HTML5 player on the station home page (www.shadowyrealms.com).
 

Support

Level 1 Support
Staff member
Is there any reason why this error would show up in Firefox if my station (Shadowy Realms) is a v2 Shoutcast station? The station is HTML5 friendly, as is evidenced by the functional HTML5 player on the station home page (www.shadowyrealms.com).
Hi Pilgrim,

Your station is working fine for us in Firefox. We recommend just clearing your browsers cache and trying again or trying another web browser instead.

shadowyrealms.png
 

Support

Level 1 Support
Staff member
Bonjour, j'ai ce problème depuis aujourd'hui !!!
Hi, this issue was fixed by Google themselves well over a year ago now.

We just tested your stream in Firefox and Chrome and it is working fine for us. We recommend just clearing your browsers cache and trying again or trying another web browser instead.

sensuelleradio.png
 

Support

Level 1 Support
Staff member
It is not working again on Chrome.
Yep, happening to us and many of our listeners as well!
Hi gulbis37 and realdanceradio,

Yes this has come to our attention this morning. We are getting quite a few emails today about the latest Chrome update rendering the web players unusable.

We'll need to take a look into this and see what solution that we can find. We'll likely keep everyone updated with a forum post but for now I recommend just using a different web browser instead.
 

gulbis37

Member
Hi gulbis37 and realdanceradio,

Yes this has come to our attention this morning. We are getting quite a few emails today about the latest Chrome update rendering the web players unusable.

We'll need to take a look into this and see what solution that we can find. We'll likely keep everyone updated with a forum post but for now I recommend just using a different web browser instead.
for me,radio owner,it is not a big trouble but for listeners,who use Chrome on Windows ...
 

MoveDaHouse

New Member
Browsers are starting to implement default blocking on insecured elements within Web pages, chrome is already doing this with its latest version, simular to what happened with flash its disabled by default now, to fix it you can goto chrome / site settings by clicking the exclamation mark in the left of the url bar click on site settings then scroll down to insecured content & select allow, this will create an exception for that particular site & run it as normal. hope this helps for now until theres a fix.
 

Support

Level 1 Support
Staff member
Browsers are starting to implement default blocking on insecured elements within Web pages, chrome is already doing this with its latest version, simular to what happened with flash its disabled by default now, to fix it you can goto chrome / site settings by clicking the exclamation mark in the left of the url bar click on site settings then scroll down to insecured content & select allow, this will create an exception for that particular site & run it as normal. hope this helps for now until theres a fix.
Thanks MoveDaHouse, that is helpful to users of the website.
 

DANCERADIOUK

New Member
Lads the time has come for you to offer https streaming as standard. You already have a certificate for your domain name so implementing it across your sub domains should be easy. Trying to get visitors to a website to use another browser or change the settings within the browser isn't an option, the listener will go elsewhere, nice idea though but it isn't a fix. Chrome did this a while ago and it is quite clear that everything now needs to be https on the web, or your browser will simply block it. Mixed content isn't the way forward. So lads, time to stay up late and get coding and get https enabled on all the accounts you host here, then you'll have happy customers. Other hosts are offering this service and as we pay a premium here, this should be offered as standard, not an optional extra you have to pay for.
 

MoveDaHouse

New Member
Lads the time has come for you to offer https streaming as standard. You already have a certificate for your domain name so implementing it across your sub domains should be easy. Trying to get visitors to a website to use another browser or change the settings within the browser isn't an option, the listener will go elsewhere, nice idea though but it isn't a fix. Chrome did this a while ago and it is quite clear that everything now needs to be https on the web, or your browser will simply block it. Mixed content isn't the way forward. So lads, time to stay up late and get coding and get https enabled on all the accounts you host here, then you'll have happy customers. Other hosts are offering this service and as we pay a premium here, this should be offered as standard, not an optional extra you have to pay for.
yes totally agree .... it wont be long before all browsers are blocking insecure content by default
 

DANCERADIOUK

New Member
100% agree. This has been coming for a while and no one should be surprised really. Yes Chrome rolled back their update last time, and they might do it again this time, but i bet they won't again. For hosts it will be a simple case of evolution, you evolve or you die.
 
Top